using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:((?<=\[)(.*?)(?=\])))+";
string substitution = @"";
string input = @"[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}