using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[\w']+(?:[^\w\n]+[\w']+){0,2}\b";
string input = @"Lorem ipsum dolor sit amet consectetur adipiscing elit sed do eiusmod tempor incididunt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}