re = /\b[\w']+(?:[^\w\n]+[\w']+){0,2}\b/
str = 'Lorem ipsum dolor sit amet consectetur adipiscing elit sed do eiusmod tempor incididunt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end