package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\w']+(?:[^\w\n]+[\w']+){0,2}\b`)
var str = `Lorem ipsum dolor sit amet consectetur adipiscing elit sed do eiusmod tempor incididunt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}