$re = '/\b[\w\']+(?:[^\w\n]+[\w\']+){0,2}\b/';
$str = 'Lorem ipsum dolor sit amet consectetur adipiscing elit sed do eiusmod tempor incididunt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);