import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([#№\\p{Sc}]?\\d+[%\\p{Sc}]?)|(\\p{P}?\\s*)|(\\w+))$";
final String string = "12\n"
+ "пробел\n"
+ "ert\n"
+ ",пробел\n"
+ "erw12\n"
+ "все показывает не подошло, а я думаю что только последнее не подходить должно\n"
+ "в чем ошибся?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}