$re = '/^(([#№\p{Sc}]?\d+[%\p{Sc}]?)|(\p{P}?\s*)|(\w+))$/m';
$str = '12
пробел
ert
,пробел
erw12
все показывает не подошло, а я думаю что только последнее не подходить должно
в чем ошиб ся?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);