const regex = /^(([#№\p{Sc}]?\d+[%\p{Sc}]?)|(\p{P}?\s*)|(\w+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([#№\\p{Sc}]?\\d+[%\\p{Sc}]?)|(\\p{P}?\\s*)|(\\w+))$', 'gm')
const str = `12
пробел
ert
,пробел
erw12
все показывает не подошло, а я думаю что только последнее не подходить должно
в чем ошибся?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}