$re = '/(?:\[.+\])/m';
$str = 'related to such contracts.[79]
References[edit]
smart contract platform.[65][66]
Quorum.[63] It\'s designed
separate version became Ethereum (ETH) with the theft reversed,[12]
and the original chain continued as Ethereum Classic (ETC).[13]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;