package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+/\d+(?: \d+/\d+)*(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b`)
var str = `BP 128/80 128/81 128/82
BP 128/80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}