import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:BP:?(?:-Sitting)?|Blood Pressure) \\d+/\\d+(?: \\d+/\\d+)*(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \\d+|(?:Sys|Dias)tolic Blood Pressure \\d+ \\w+\\b";
final String string = "BP 128/80 128/81 128/82\n"
+ "BP 128/80";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}