const regex = new RegExp('\\b(?:BP:?(?:-Sitting)?|Blood Pressure) \\d+/\\d+(?: \\d+/\\d+)*(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \\d+|(?:Sys|Dias)tolic Blood Pressure \\d+ \\w+\\b', 'gm')
const str = `BP 128/80 128/81 128/82
BP 128/80`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}