re = /\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+\/\d+(?: \d+\/\d+)*(?: mmHg?)?|B\/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b/m
str = 'BP 128/80 128/81 128/82
BP 128/80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end