#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$"
Local $sString = "file.txt" & @CRLF & _
"file.txt.txt" & @CRLF & _
"file.one.two.thre" & @CRLF & _
"file.one.two.three" & @CRLF & _
"file.google.txt.jar" & @CRLF & _
"jim.joe.chris" & @CRLF & _
"something.filename.pdf.lnk" & @CRLF & _
"filename.pdf.123" & @CRLF & _
"thisfile.hasadotbutonlyone.exe" & @CRLF & _
"thisfile.xlsx.xlsx" & @CRLF & _
"thisfile.12.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")