import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w.]{1,})\\.([\\w]{3,4})\\.([\\w]{3,4})$";
final String string = "file.txt\n"
+ "file.txt.txt\n"
+ "file.one.two.thre\n"
+ "file.one.two.three\n"
+ "file.google.txt.jar\n"
+ "jim.joe.chris\n"
+ "something.filename.pdf.lnk\n"
+ "filename.pdf.123\n"
+ "thisfile.hasadotbutonlyone.exe\n"
+ "thisfile.xlsx.xlsx\n"
+ "thisfile.12.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}