re = /^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$/m
str = 'file.txt
file.txt.txt
file.one.two.thre
file.one.two.three
file.google.txt.jar
jim.joe.chris
something.filename.pdf.lnk
filename.pdf.123
thisfile.hasadotbutonlyone.exe
thisfile.xlsx.xlsx
thisfile.12.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end