import re
regex = re.compile(r"^([A-Z][\d]|[\d][A-Z]|[A-Z]{2})(\d{1,})$", flags=re.MULTILINE)
test_str = ("KL1234\n"
"9F1\n"
"K9123\n"
"2345\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")