using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test\d+(.+)(?:test\d+|}})$";
string input = @"test1 I'm a potato! I <3 Potato. test1}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}