re = /^test\d+(.+)(?:test\d+|}})$/
str = 'test1 I\'m a potato! I <3 Potato. test1}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end