$re = '/^test\d+(.+)(?:test\d+|}})$/';
$str = 'test1 I\'m a potato! I <3 Potato. test1}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);