package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^test\d+(.+)(?:test\d+|}})$`)
var str = `test1 I'm a potato! I <3 Potato. test1}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}