use strict;
my $str = 'Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.
(https://example.com/abc/1.html)
Also have a look at https://example.com/abc/1.html';
my $regex = qr/(?<!\]\()(\b(https?|ftp):\/\/[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|])(?!\]\()/mip;
my $subst = '[$1]($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";