import re
regex = re.compile(r"(?<!\]\()(\b(https?|ftp):\/\/[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|])(?!\]\()", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.\n\n"
"(https://example.com/abc/1.html)\n\n"
"Also have a look at https://example.com/abc/1.html")
subst = "[$1]($1)"
result = regex.sub(subst, test_str)
if result:
print(result)