$re = '/(?<!\]\()(\b(https?|ftp):\/\/[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|])(?!\]\()/mi';
$str = 'Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.
(https://example.com/abc/1.html)
Also have a look at https://example.com/abc/1.html';
$subst = "[$1]($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;