import re
regex = re.compile(r"(^\+\d\s\(\d{3}\)\s\d{3}\-\d{4}$|^\+\d{1,3}\s\d{2,3}\s\d{2,3}\s\d{2,3}\s\d{2})", flags=re.MULTILINE)
test_str = ("+1 (555) 555-5555\n"
"+1 (555) 555-55555\n"
"+90 532 581 98 18\n"
"+90 532 581 98 186\n"
"+358 44 944 30 13\n"
"+358 44 944 30 133")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")