use strict;
my $str = 'AT-0815-5600
AT-0815-5600-X
AT-0815-5500
DE-0815-5601
CH-0815-5602
CH-0815-5602-X
SI-1234-1234-X';
my $regex = qr/(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})$)|(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})\-X$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}