import Foundation
let pattern = #"(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})$)|(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})\-X$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AT-0815-5600
AT-0815-5600-X
AT-0815-5500
DE-0815-5601
CH-0815-5602
CH-0815-5602-X
SI-1234-1234-X
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)