$re = '/(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})$)|(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})\-X$)/m';
$str = 'AT-0815-5600
AT-0815-5600-X
AT-0815-5500
DE-0815-5601
CH-0815-5602
CH-0815-5602-X
SI-1234-1234-X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);