import re
regex = re.compile(r"(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})$)|(^(DE|AT|CH|SI)\-([0-9]{4}|A000)\-(560[0-5]{1})\-X$)", flags=re.MULTILINE)
test_str = ("AT-0815-5600\n"
"AT-0815-5600-X\n"
"AT-0815-5500\n"
"DE-0815-5601\n"
"CH-0815-5602\n"
"CH-0815-5602-X\n"
"SI-1234-1234-X")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")