using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span[^>]+>(.*?)</span>";
string input = @"<td class=""class2""> </td>
<td class=""class2"" align=""right""><span class=""DarkText"">I WANT THIS TEXT</span></td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}