import re
regex = re.compile(r"<span[^>]+>(.*?)</span>", flags=re.MULTILINE)
test_str = ("<td class=\"class2\"> </td>\n"
"<td class=\"class2\" align=\"right\"><span class=\"DarkText\">I WANT THIS TEXT</span></td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")