re = /<span[^>]+>(.*?)<\/span>/m
str = '<td class="class2"> </td>
<td class="class2" align="right"><span class="DarkText">I WANT THIS TEXT</span></td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end