package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(((?:[^()]|(?R))*)\)`)
var str = `((Lorem) ipsum dolor sit amet)
(consectetur adipiscing elit.)(Etiam
suscipit
pulvinar congue.)
((Vivamus) eu faucibus enim.)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}