import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(((?:[^()]|(?R))*)\\)";
final String string = "((Lorem) ipsum dolor sit amet)\n"
+ "(consectetur adipiscing elit.)(Etiam\n"
+ "suscipit\n"
+ "pulvinar congue.)\n"
+ "((Vivamus) eu faucibus enim.)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}