re = /\(((?:[^()]|(?R))*)\)/
str = '((Lorem) ipsum dolor sit amet)
(consectetur adipiscing elit.)(Etiam
suscipit
pulvinar congue.)
((Vivamus) eu faucibus enim.)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end