#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http(?:s)?:\/\/)?(?:(?:www)\.(?:tiktok\.com)(?:\/)(?!foryou)(@[a-zA-z0-9]+)(?:\/)(?:video)(?:\/)([\d]+)|(?:m)\.(?:tiktok\.com)(?:\/)(?!foryou)(?:v)(?:\/)?(?=([\d]+)\.html))"
Local $sString = "https://m.tiktok.com/h5/share/usr/6641141594707361797.html" & @CRLF & _
"" & @CRLF & _
"https://www.tiktok.com/embed/6567659045795758085" & @CRLF & _
"https://www.tiktok.com/share/user/6567659045795758085" & @CRLF & _
"https://www.tiktok.com/trending?shareId=6744531482393545985" & @CRLF & _
"" & @CRLF & _
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411" & @CRLF & _
"" & @CRLF & _
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411" & @CRLF & _
"" & @CRLF & _
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.tiktok.com/v/6749869095467945218.html" & @CRLF & _
"https://www.tiktok.com/v/6749869095467945218" & @CRLF & _
"https://m.tiktok.com/v/6749869095467945218" & @CRLF & _
"https://m.tiktok.com/@cchelseameow/video/6751181801206729990" & @CRLF & _
"https://m.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://m.tiktok.com/v/6749869095467945218.html" & @CRLF & _
"https://www.tiktok.com/@cchelseameow/video/6751181801206729990" & @CRLF & _
"https://www.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")