import re
regex = re.compile(r"(?:http(?:s)?:\/\/)?(?:(?:www)\.(?:tiktok\.com)(?:\/)(?!foryou)(@[a-zA-z0-9]+)(?:\/)(?:video)(?:\/)([\d]+)|(?:m)\.(?:tiktok\.com)(?:\/)(?!foryou)(?:v)(?:\/)?(?=([\d]+)\.html))", flags=re.MULTILINE)
test_str = ("https://m.tiktok.com/h5/share/usr/6641141594707361797.html\n\n"
"https://www.tiktok.com/embed/6567659045795758085\n"
"https://www.tiktok.com/share/user/6567659045795758085\n"
"https://www.tiktok.com/trending?shareId=6744531482393545985\n\n"
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411\n\n"
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411\n\n"
"https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411\n\n\n"
"https://www.tiktok.com/v/6749869095467945218.html\n"
"https://www.tiktok.com/v/6749869095467945218\n"
"https://m.tiktok.com/v/6749869095467945218\n"
"https://m.tiktok.com/@cchelseameow/video/6751181801206729990\n"
"https://m.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc\n\n\n\n"
"https://m.tiktok.com/v/6749869095467945218.html\n"
"https://www.tiktok.com/@cchelseameow/video/6751181801206729990\n"
"https://www.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")