using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[a-z][a-z0-9.-]{1,14}[a-z0-9]$)(?!.*--)[a-z0-9-]+(?:\.[a-z][a-z0-9-]+[a-z0-9])*$";
string input = @"test
test.test
ab1
abc.ab9.a-c
abc.abc.a-c.a-3
aaa
a-a-a
a-3
abc.abc.a-c.-b-a
test.t
test--s
abc.ab9.a--
2-a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}