import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[a-z][a-z0-9.-]{1,14}[a-z0-9]$)(?!.*--)[a-z0-9-]+(?:\\.[a-z][a-z0-9-]+[a-z0-9])*$";
final String string = "test\n"
+ "test.test\n"
+ "ab1\n"
+ "abc.ab9.a-c\n"
+ "abc.abc.a-c.a-3\n"
+ "aaa\n"
+ "a-a-a\n"
+ "a-3\n\n"
+ "abc.abc.a-c.-b-a\n"
+ "test.t\n"
+ "test--s\n"
+ "abc.ab9.a--\n"
+ "2-a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}