re = /^(?=[a-z][a-z0-9.-]{1,14}[a-z0-9]$)(?!.*--)[a-z0-9-]+(?:\.[a-z][a-z0-9-]+[a-z0-9])*$/m
str = 'test
test.test
ab1
abc.ab9.a-c
abc.abc.a-c.a-3
aaa
a-a-a
a-3
abc.abc.a-c.-b-a
test.t
test--s
abc.ab9.a--
2-a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end