import Foundation
let pattern = #"^(?=[a-z][a-z0-9.-]{1,14}[a-z0-9]$)(?!.*--)[a-z0-9-]+(?:\.[a-z][a-z0-9-]+[a-z0-9])*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test
test.test
ab1
abc.ab9.a-c
abc.abc.a-c.a-3
aaa
a-a-a
a-3
abc.abc.a-c.-b-a
test.t
test--s
abc.ab9.a--
2-a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)