#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}"
Local $sString = "Верный текст:" & @CRLF & _
"some textssl.verify: false some text" & @CRLF & _
" git config http.sslVerify "false"" & @CRLF & _
"some textssl.verify: false" some text" & @CRLF & _
"some text = "sslVerify \"false\"" some text" & @CRLF & _
"some text = "sslVerify \"false\"" some text" & @CRLF & _
"some text = sslVerify=false"some text" & @CRLF & _
"some text = "sslVerify 'false' some text" & @CRLF & _
"some text.sslVerify=\"false\"" some text" & @CRLF & _
"some text"sslVerify = \"false\""some text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Не должно проходить валидацию:" & @CRLF & _
"some text"sslVerify = some text \"false\""some text" & @CRLF & _
"some text"ssl Verify = "false""some text" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")