// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}"#).unwrap();
let string = "Верный текст:
some textssl.verify: false some text
git config http.sslVerify \"false\"
some textssl.verify: false\" some text
some text = \"sslVerify \\\"false\\\"\" some text
some text = \"sslVerify \\\"false\\\"\" some text
some text = sslVerify=false\"some text
some text = \"sslVerify 'false' some text
some text.sslVerify=\\\"false\\\"\" some text
some text\"sslVerify = \\\"false\\\"\"some text
Не должно проходить валидацию:
some text\"sslVerify = some text \\\"false\\\"\"some text
some text\"ssl Verify = \"false\"\"some text
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}