package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}`)
var str = `Верный текст:
some textssl.verify: false some text
git config http.sslVerify "false"
some textssl.verify: false" some text
some text = "sslVerify \"false\"" some text
some text = "sslVerify \"false\"" some text
some text = sslVerify=false"some text
some text = "sslVerify 'false' some text
some text.sslVerify=\"false\"" some text
some text"sslVerify = \"false\""some text
Не должно проходить валидацию:
some text"sslVerify = some text \"false\""some text
some text"ssl Verify = "false""some text
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}