import re
regex = re.compile(r"ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}", flags=re.IGNORECASE)
test_str = ("Верный текст:\n"
"some textssl.verify: false some text\n"
" git config http.sslVerify \"false\"\n"
"some textssl.verify: false\" some text\n"
"some text = \"sslVerify \\\"false\\\"\" some text\n"
"some text = \"sslVerify \\\"false\\\"\" some text\n"
"some text = sslVerify=false\"some text\n"
"some text = \"sslVerify 'false' some text\n"
"some text.sslVerify=\\\"false\\\"\" some text\n"
"some text\"sslVerify = \\\"false\\\"\"some text\n\n\n"
"Не должно проходить валидацию:\n"
"some text\"sslVerify = some text \\\"false\\\"\"some text\n"
"some text\"ssl Verify = \"false\"\"some text\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")