package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(.*?),\s*(.*)$`)
var str = `Addams family, The
Zelda, The Legend of`
var substitution = "$2 $1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}