$re = '/^(.*?),\s*(.*)$/im';
$str = 'Addams family, The
Zelda, The Legend of';
$subst = "$2 $1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;