import re
regex = re.compile(r"^(.*?),\s*(.*)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Addams family, The\n"
"Zelda, The Legend of")
subst = "$2 $1 "
result = regex.sub(subst, test_str)
if result:
print(result)