const regex = /^(.*?),\s*(.*)$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?),\\s*(.*)$', 'img')
const str = `Addams family, The
Zelda, The Legend of`;
const subst = `$2 $1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);