using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.+?src=[""'](.+?)[""'].*?>";
string input = @"// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class=""hero-class"" src=""image.jpg"">
// it shouldn't match custom attribute 'data-src'
<img data-src=""custom info"" src=""image.jpg"">
// it should match whole src attribute, not just part
<img class=""hero-class"" src=""mcdonald's.jpg"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}